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8.  Excel Charts and Analysis ToolPak 
 

Charts, also known as graphs, have been an integral part of spreadsheets since the 
early days of Lotus 1-2-3.  Charting features have improved significantly over the years, 
and you’ll find that Excel provides you with the tools to create a wide variety of highly 
customizable charts.  
 
8.1 Chart Basics 

 
Basically, a chart presents a table of numbers visually.  Displaying data in a well-

conceived chart can make the data more understandable, and you often can make your 
point more quickly as a result. Because a chart presents a picture, charts are particularly 
useful for understanding a lengthy series of numbers and their interrelationships. Making 
a chart helps you to spot trends and patterns that would be nearly impossible to identify 
when examining a range of numbers. 
 

You create charts from numbers that appear in a worksheet.  Before you can 
create a chart, you must enter some numbers in a worksheet. Normally, the data that is 
used by a chart resides in a single worksheet within one file but that’s not a strict 
requirement. A single chart can use data from any number of worksheets or even from 
different workbooks. 
 

When you create a chart in Excel, you have two options for where to place the 
chart: 

 
o Insert the chart directly into a worksheet as an object. A chart like the one that 

appears in Figure1 is known as an embedded chart. 
o Create the chart as a new chart sheet in your workbook (Figure 2). A chart sheet 

differs from a worksheet in that a chart sheet can hold a single chart and doesn’t 
have cells. 

 
(1) Chart types 
 
 You’re probably aware of the many types of charts: bar charts, line charts, pie 
charts, and so on. Excel enables you to create all the basic chart types, and even some 
esoteric chart types, such as radar charts and doughnut charts.  The following is a list of 
Excel basic chart types: 

 
Area 
Bar 
Column 
Line 
Pie 
Doughnut 
Radar 
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Figure 1.  An embedded chart on a worksheet. 
 

 
Figure 2.  A separate chart sheet. 
 

XY (Scatter) 
Surface 
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Bubble  
Stock 
Cylinder 
Cone 
Pyramid 

 
Beginning chart makers commonly ask how to determine the most appropriate 

chart type for the data. No good answer exists to this question, and I’m not aware of any 
hard-and-fast rules for determining which chart type is best for your data.  Perhaps the 
best rule is to use the chart type that gets your message across in the simplest way. 
 
(2) The Chart wizard 
 
 You use the Chart Wizard to create a chart. The Chart Wizard consists of a series 
of dialog boxes that guide you through the process of creating the exact chart that you 
need. Figure 3 shows the first of four Chart Wizard dialog boxes. 
 

 
Figure 3.  Chart wizard dialog box. 
 
 
(3) How Excel handles charts 
 
 A chart is essentially an object that Excel creates. This object consists of one or 
more data series, displayed graphically; the appearance of the data series depends on the 
selected chart type. For example, if you create a line chart that uses two data series, the 
chart contains two lines - each representing one data series. You can distinguish each of 
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the lines by its thickness, color, and data markers. The data series in the chart are linked 
to cells in the worksheet. 
 

You can include a maximum of 255 data series in most charts; the exception is a 
standard pie chart, which can display only one data series. If your chart uses more than 
one data series, you may want to use a legend to help the reader identify each series. 
Excel also places a limit on the number of categories (or data points) in a data series: 
32,000 (4,000 for 3D charts). Most users never run up against this limit. 
 

Charts can use different numbers of axes: 
 

o Common charts, such as column, line, and area charts, have a category axis and a 
value axis. The category axis normally is the horizontal axis, and the value axis 
normally is the vertical axis (this is reversed for bar charts, in which the bars 
extend from the left of the chart rather than from the bottom). 

o Pie charts and doughnut charts have no axes (but they do have calories). A pie 
chart can display only one data series. A doughnut chart can display multiple data 
series. 

o A radar chart is a special chart that has one axis for each point in the data series. 
The axes extend from the center of the chart. 

o True 3D charts have three axes: a category axis, a value axis, and a series axis that 
extends into the third dimension.  

 
A chart is not stagnant. You can always change its type, add custom formatting, 

add new data series to it, or change an existing data series so that it uses data in a 
different range. Before you create a chart, you need to determine whether you want it to 
be an embedded chart or a chart that resides on a chart sheet. 
 
 

Creating an Embedded Chart with Chart Wizard: 
 
To invoke the Chart Wizard to create an embedded chart: 

 
(a)  Select the data to be charted (optional). 
(b)  Choose Insert -> Chart (or, click the Chart Wizard tool on the Standard 
toolbar). 
(c)  Make your choices in Steps 1 through 3 of the Chart Wizard. 
(d)  In Step 4 of the Chart Wizard, select the option labeled As object in. 

 
 
Creating a Chart on a Chart Sheet with the Chart Wizard: 
 
To start the Chart Wizard and create an embedded chart first: 
(a)  Select the data that you want to chart (optional). 
(b)  Choose Insert -> Chart (or click the Chart Wizard tool on the Standard 
toolbar). 
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(c)  Make your choices in Steps 1 through 3 of the Chart Wizard. 
(d)  In Step 4 of the Chart Wizard, select the option labeled As new sheet. 

 
(4) An example of using Excel chart wizard 
 
 The Chart Wizard consists of four dialog boxes that prompt you for various 
settings for the chart. By the time that you reach the last dialog box, the chart is usually 
just what you need. 
 

Selecting the Data: 
 
Before you start the Chart Wizard, select the data that you want to include in the 

chart. This step isn’t necessary, but it makes creating the chart easier for you. If you don’t 
select the data before invoking the Chart Wizard, you can select it in the second Chart 
Wizard dialog box.  However, I prefer to select the data before starting the wizard. 
 

When you select the data, include items such as labels and series identifiers (row 
and column headings). Figure 4 shows a worksheet with a range of data set up for a chart. 
This data consists of the average tract size harvested annually in West Virginia. You 
would select the entire range for this worksheet as I did in Figure 4. 
 

 
Figure 4.  Data for a chart. 

After you select the data, start the Chart Wizard, either by clicking the Chart 
Wizard button on the Standard toolbar or by selecting Insert -> Chart. Excel displays the 
first of four Chart Wizard dialog boxes. 
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Step 1: 
 
 The Chart Wizard dialog box will be the first thing popped out, in which you 
select the chart type (Figure 5). This dialog box has two tabs: Standard Types and 
Custom Types. The Standard Types tab displays the 14 basic chart types and the subtypes 
for each. The Custom Types tab displays some customized charts (including user-defined 
custom charts).  
 

 
Figure 5.  First chart wizard dialog box. 
 
 For example, if I decided to use column chart, I need to click the Next button to 
move to the next step. 
 
 Step 2: 
 
 In the second step of the Chart Wizard (Figure 6), you verify the data ranges and 
specify the orientation of the data (whether it’s arranged in rows or columns). The 
orientation of the data has a drastic effect on the look of your chart. 
Usually, Excel guesses the orientation correctly - but not always. 
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Figure 5. Second chart wizard dialog box. 
 
 Apparently, the chart I have is not in the format I want.  I should do some work 
here.  First, click series tab, copy the data in series 1 to category x-axis, and then remove 
series 1 data (Figure 6). 
 

 
Figure 6.  Adjustment of data series. 
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 After this adjustment is done, click Next button to proceed to the next step. 
 
 Step 3: 
  

In the third Chart Wizard dialog box (Figure 7), you specify most of the options 
for the chart. This dialog box has six tabs: 
 

o Titles: Add titles to the chart. 
o Axes: Turn on or off axes display and specify the type of axes. 
o Gridlines: Specify gridlines, if any. 
o Legend: Specify whether to include a legend and where to place it. 
o Data Labels: Specify whether to show data labels and what type of labels. 
o Data Table: Specify whether to display a table of the data. 

 

 
Figure 7.  Chart options in the third wizard dialog box. 
 
 I also clicked the legend tab and checked out the show legend box.  Click Next 
button to move to the final step. 
 
 Step 4: 
 
 Step 4 of the Chart Wizard lets you specify where to place the chart. Make your 
choice and click Finish (Figure 8).  Excel creates and displays the chart. If you place the 
chart on a worksheet, Excel centers it in the worksheet window and selects it. 
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Figure 8.  Fourth dialog box of chart wizard. 
 
 
(5) Chart modifications 
  

After you create a chart, you can modify it at any time. The modifications that 
you can make to a chart are extensive. This section covers some of the more common 
chart modifications: 
 

o Moving and resizing the chart 
o Changing a chart’s location 
o Changing the chart type 
o Moving chart elements 
o Deleting chart elements 
 

The most important thing you can do here is to copy the chart and paste it either 
to your MS Word file or your PowerPoint presentation. 
 
 
8.2 Enhancing Chart with Pictures and Drawings 
 

Excel can import a wide variety of graphics files into a worksheet. You have 
several choices: 
 

o Use the Microsoft Clip Gallery to locate and insert an Image 
o Directly import a graphic file 
o Copy and paste the image by using the Windows Clipboard 
o Import the image from a digital camera or scanner 

 
(1) Using the clip gallery 

 
The Clip Gallery is a shared application that is also accessible from other 

Microsoft Office products.  You access the Clip Gallery by selecting the Insert -> Picture 
-> Clip Art command.  This displays the Insert ClipArt dialog box, shown in Figure 9. 
Click the Pictures tab and then click a category, and the images in that category appear. 
Locate the image that you want and click it. A graphic menu pops up from which you can 
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choose to insert the image, preview the image, add the image to your “favorites,” or find 
similar images. You can also search for clip art by keyword —just enter some text in the 
Search for clips box, and the matching images are displayed. 
 

 
Figure 9.  Clip art dialog box. 
 
(2) Importing graphics files 
 

If the graphic image that you want to insert is available in a file, you can easily 
import the file into your worksheet by choosing Insert -> Picture -> From File. Excel 
displays the Insert Picture dialog box (Figure 10). This dialog box works just like the 
Open dialog box. By default, it displays only the graphics files that Excel can import. If 
you choose the Preview option, Excel displays a preview of the selected file in the right 
panel of the dialog box. 
 
 The most common graphics file formats that Excel can import are JPG, GIF, and 
BMP. 
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Figure 10.  Insert picture dialog box. 
 
(3) Copying graphics by using the clipboard 
  
 In some cases, you may want to use a graphic image that is not stored in a 
separate file or that is in a file that Excel can’t import. For example, you may have a 
drawing program that uses a file format that Excel doesn’t support. You may be able to 
export the file to a supported format, but it may be easier to load the file into the drawing 
program and copy the image to the Clipboard. Then, you can activate Excel and paste the 
image to the draw layer. 
 
(4) Using WordArt 
 
 WordArt is an application that’s included with Microsoft Office. You can insert a 
WordArt image either by using the WordArt tool on the Drawing toolbar or by selecting 
Insert -> Picture -> WordArt. Either method displays the WordArt Gallery dialog box 
(Figure 11). Select a style and then enter your text in the next dialog box. Click OK, and 
the image is inserted in the worksheet. 
 

When you select a WordArt image, Excel displays the WordArt toolbar. Use these 
tools to modify the WordArt image. You’ll find that you have lots of flexibility with 
these tools. In addition, you can use the Shadow and 3D tools to further manipulate the 
image. Figure 12 shows an example of a WordArt image inserted on a worksheet. 
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Figure 11.  WordArt dialog box. 
 

 
Figure 12.  An example of WordArt. 
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(5) Creating combination chart  
  

A combination chart is a single chart that consists of series that use different 
chart types. For example, you may have a chart that shows both columns and lines. A 
combination chart also can use a single type (all columns, for example), but include a 
second value axis. A combination chart requires at least two data series. 
 

Creating a combination chart simply involves changing one or more of the data 
series to a different chart type. Select the data series and then choose Chart -> 
Chart Type. In the Chart Type dialog box, select the chart type that you want to apply to 
the selected series. Figure 13 and 14 show an example of a combination chart.  Suppose 
we would like to use scatter x-y chart type for observed data.   
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Figure 13.  A combined chart. 
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Figure 14.  A combined chart with scattered dots and a line. 
 

 
Excel Charts and Analysis ToolPak, Provided by Dr. Jingxin Wang 13 



FOR 240  Introduction to Computing in Natural Resources 
 

(6) Simple Gantt charts  
 

Creating a simple Gantt chart isn’t difficult when using Excel, but it does require 
some setup work. Gantt charts are used to represent the time required to perform each 
task in a project. Figure 15 shows data that was used to create the Gantt chart in Figure 
16. 
 

 
Figure 15.  Data for a Gantt chart. 
 
 

Here are the steps to create this chart: 
 

(a) Enter the data as shown in Figure 15. The formula in cell D3, which was 
copied to the rows below it, is =B3+C3-1. 

(b) Use the Chart Wizard to create a stacked bar chart from the range A3:C10.  
Use the second subtype, which is labeled Stacked Bar. 

(c) In Step 2 of the Chart Wizard, select the Columns option. Also, notice that 
Excel incorrectly uses the first two columns as the Category axis labels. 

(d) In Step 2 of the Chart Wizard, click the Series tab and add a new data series.  
Then, set the chart’s series to the following: 

Series 1: B3:B10 
Series 2: C3:C10 
Category (x) axis labels: A3:A10 

(e) In Step 3 of the Chart Wizard, remove the legend and then click Finish to 
create an embedded chart. 
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(f) Adjust the height of the chart so that all the axis labels are visible. You can 
also accomplish this by using a smaller font size. 

(g) Access the Format Axis dialog box for the horizontal axis. Adjust the 
horizontal axis Minimum and Maximum scale values to correspond to the 
earliest and latest dates in the data (note that you can enter a date into the 
Minimum or Maximum edit box). You might also want to change the date 
format for the axis labels. 

(h) Access the Format Axis dialog box for the vertical axis. In the Scale tab, 
select the option labeled Categories in reverse order, and also set the option 
labeled Value (y) axis crosses at maximum category. 

(i) Select the first data series and access the Format Data Series dialog box. In the 
Patterns tab, set Border to None and Area to None. This makes the first data 
series invisible. 

(j) Apply other formatting, as desired. 
 

Logger Survey Project Schedule
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Planning Meeting
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Data Entry

Data Analysis

Write Report

Finalize Report

Figure 16.  Schedule chart for a loggers’ survey project. 
 
 
8.3 Data Analysis with Analysis ToolPak 
 

The Analysis ToolPak is an add-in that provides analytical capability that 
normally is not available.  The following analyses are provided by ToolPak: 
 

o Analysis of variance (three types) 
o Correlation 
o Covariance 
o Descriptive statistics 
o Exponential smoothing 
o F-test 
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o Fourier analysis 
o Histogram 
o Moving average 
o Random number generation 
o Rank and percentile 
o Regression 
o Sampling 
o t-test (three types) 
o z-test 

 
As you can see, the Analysis ToolPak add-in brings a great deal of new 

functionality to Excel.   
 

(1) Install and use the Analysis ToolPak 

Before using an analysis tool, you must arrange the data you want to analyze in 
columns or rows on your worksheet. This is your input range.  If the Data Analysis 
command is not on the Tools menu, you need to install the Analysis ToolPak in 
Microsoft Excel. 

To install the Analysis ToolPak: 

• On the Tools menu, click Add-Ins (Figure 17).  

If Analysis ToolPak is not listed in the Add-Ins dialog box, click Browse and 
locate the drive, folder name, and file name for the Analysis ToolPak add-in, 
Analys32.xll — usually located in the Microsoft Office\Office\Library\Analysis 
folder — or run the Setup program if it isn't installed.  

• Select the Analysis ToolPak check box.  

To use the Analysis ToolPak: 

(a) On the Tools menu, click Data Analysis (Figure 18). 

(b) In the Analysis Tools box, click the tool you want to use. 

(c) Enter the input range and the output range, and then select the options you want.  

To remove an add-in program from Microsoft Excel: 

(a) On the Tools menu, click Add-Ins.  
(b) In the Add-Ins available box, clear the check box next to the add-in you want to 

unload. 

(c) To remove the add-in from memory, restart Excel.  
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Figure 17.  Add-ins dialog box. 
 

 
Figure 18.  Data analysis dialog box. 
 
(2) The correlation tool   
 
 Correlation is a widely used statistic that measures the degree to which two sets 
of data vary together. For example, if higher values in one data set are typically 
associated with higher values in the second data set, the two data sets have a positive 
correlation.  The degree of correlation is expressed as a coefficient that ranges from –1.0 
(a perfect negative correlation) to +1.0 (a perfect positive correlation). A correlation 
coefficient of 0 indicates that the two variables are not correlated. 
 

Figure 19 shows the Correlation dialog box. Specify the input range, which can 
include any number of variables, arranged in rows or columns. 
 
 For example, if we would like to know the correlation between the DBH and time 
per tree in minute for a feller-buncher felling (Figure 20), we need to enter the data range 
a1:b17, check the “Labels in First Row” box, and select the output as a new sheet. 
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Figure 19.  The correlation dialog box. 
 

 
Figure 20.  Data used for the correlation tool. 
 

Figure 21 shows the results of a correlation analysis for two variables of DBH and 
Time per tree. The output consists of a correlation matrix that shows the correlation 
coefficient for each variable paired with every other variable. 
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Figure 21.  Results of correlation analysis. 
 
 
(2) The regression tool 
 

The Regression tool calculates a regression analysis from worksheet data. Use 
regression to analyze trends, forecast the future, build predictive models, and, often, to 
make sense out of a series of seemingly unrelated numbers. 
 

Regression analysis enables you to determine the extent to which one range of 
data (the dependent variable) varies as a function of the values of one or more other 
ranges of data (the independent variables). This relationship is expressed mathematically, 
using values that Excel calculates. You can use these calculations to create a 
mathematical model of the data and predict the dependent variable by using different 
values of one or more independent variables. This tool can perform simple and multiple 
linear regressions and calculate and standardize residuals automatically. 
 

Figure 22 shows the Regression dialog box. 
 
As you can see, the Regression dialog box offers many options: 

o Input Y Range: The range that contains the dependent variable. 
o Input X Range: One or more ranges that contain independent variables. 
o Confidence Level: The confidence level for the regression. 
o Constant is Zero: If checked, this forces the regression to have a constant of zero 

(which means that the regression line passes through the origin; when the X 
values are 0, the predicted Y value is 0). 

o Residuals: These options specify whether to include residuals in the output. 
Residuals are the differences between observed and predicted values. 

o Normal Probability: This generates a chart for normal probability plots. 
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Figure 22.  The regression dialog box. 
 
 For example, if we still use the same data set for the feller-buncher (Figure 20), 
enter the Y range b1:b17 and X range a1:a17, check labels and confidence level boxes, 
and select the output as a new sheet, we will have the regression summary (Figure 23). 
 
 There are a couple of things I would like to explain here.  Based on the coefficient 
column, we can get the model, in this case: 
 

Time = 0.406 + 0.013*DBH 
 
To determine whether or not this model is usable, we usually use the following 

statistics: 
 

o R-square 
o MS or root MS 
o F value 
o P-value 
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Figure 23.  Sample output from the regression tool. 

 
 
 
Class Exercises 
 
 (1) Lab 3. 
 
 
References 

Walkenbach, J.  1999.  Microsoft Excel 2000 Bible.  IDG Books Worldwide, Inc.  Foster 
City, CA. 

  

 
Excel Charts and Analysis ToolPak, Provided by Dr. Jingxin Wang 21 


