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5.  Excel Fundamentals 
 
 

Excel is a software product that falls into the general category of spreadsheets.  
Excel is one of several spreadsheet products that you can run on your PC.  Others include 
1-2-3 and Quattro Pro. 
 

A spreadsheet (including Excel) is a highly interactive computer program that 
consists of a collection of rows and columns displayed onscreen in a scrollable window. 
The intersection of each row and column is called a cell, which can hold a number, a text 
string, or a formula that performs a calculation by using one or more other cells. Copying 
and moving cells and modifying formulas are easy with a spreadsheet. 

 
The most significant advantage of an electronic spreadsheet is that the formulas 

recalculate their results if you change any of the cells that they use. As a result, after you 
set up your spreadsheet by defining formulas, you can use this “model” to explore 
different possibilities, with very little additional effort. 
 
5.1 Evolution of Excel 

 
There are quite a few versions of MS Excel.  Excel 2003 is the most current 

version. 
 
Excel 2 was the original version of Excel for Windows, which first appeared in 

late 1987. It was labeled Version 2 to correspond to the Macintosh version, which was 
the original Excel. Because Windows wasn’t in widespread use at the time, Version 2 
included a run-time version of Windows—a special version with just enough features to 
run Excel and nothing else. 

  
At the end of 1990, Microsoft released Excel 3 for Windows. This was a 

significant improvement in both appearance and features. It included toolbars, drawing 
capabilities, worksheet outlining, add-in support, 3D charts, workgroup editing, and lots 
more. 

Excel 4 hit the streets in the spring of 1992. This version made quite an impact in 
the marketplace, because Windows was becoming more popular. It had lots of new 
features, many of which made it easier for beginners to get up to speed quickly. 

 
In early 1994, Excel 5 appeared on the scene. This version introduced tons of new 

features, including multi-sheet workbooks and the new Visual Basic for Applications 
(VBA) macro language. Like its predecessor, Excel 5 took top honors in just about every 
spreadsheet comparison that was published in the trade magazines. 

 
Technically, the Excel 6 was called Excel for Windows 95 (there was no Excel 6). 

It began shipping in the summer of 1995. On the surface, this version wasn’t that much 
different from Excel 5, and included only a few major new features. But Excel 7 was 
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significant, because it was the first version to use the more advanced 32-bit code. Excel 7 
and Excel 5 used the same file format. 

 
Excel 8 (officially known as Excel 97) was probably the most significant Excel 

upgrade ever. The toolbars and menus had a great new look, online help took a dramatic 
step forward, and the number of rows available in a worksheet quadrupled. Developers 
were pleased to discover that Excel’s programming language (VBA) improved 
significantly in Excel 97.  Excel 9 (better known as Excel 2000) is the topic of this book. 
Excel 2000 has quite a few enhancements, but its most significant advancement is the 
capability to use HTML as a standard file format.  Excel 2003 is the most current version 
of MS Excel spreadsheet. 
 
 
6.2 Navigating through Excel 
 

The files that Excel uses are known as workbooks. A workbook can hold any 
number of sheets, and these sheets can be either worksheets (a sheet consisting of rows 
and columns) or chart sheets (a sheet that holds a single chart). A worksheet is what 
people usually think of when they think of a spreadsheet. 
 

Figure 1 shows Excel with three workbooks open, each in a separate window.  
Worksheet windows can overlap so that the title bar of one window is a different color. 
That’s the window that contains the active workbook.  The workbook windows that 
Excel uses work much like the windows in any other Windows program. Excel’s 
windows can be in one of the following states: maximized, minimized, and restored. 

 
Every worksheet consists of rows (numbered 1 through 65,536) and columns 

(labeled A through IV). After column Z comes column AA; after column AZ comes 
column BA, and so on. The intersection of a row and a column is a single cell. At any 
given time, one cell is the active cell. You can identify the active cell by its darker border, 
as shown in Figure 2. Its address (its column letter and row number) appears in the Name 
box. Depending on the technique that you use to navigate through a workbook, you may 
or may not change the active cell when you navigate. 
 

Consider how big a worksheet really is. It has 256 columns and 65,536 rows. Do 
the arithmetic and you’ll find that this works out to 16,777,216 cells. Remember, this is 
in just one worksheet. A single workbook can hold more than one worksheet —hundreds, 
if necessary. 
 
 There are two types of menus you can use to manipulate data and other items with 
Excel.  The regular menu is on the menu bar and lists all the functionalities the Excel has.  
The other type of menu is called shortcut menu.  A shortcut menu is context-sensitive —
its contents depend on what you’re doing at the time. Shortcut menus don’t contain all 
the relevant commands, just those that are most commonly used for whatever is selected. 
You can display a shortcut menu by right clicking just about anything in Excel. 
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Figure 1.  Excel with three workbooks open. 
 
 
Hiding or showing toolbars 
 

To hide or display a particular toolbar, choose View ->Toolbars, or right-click any 
toolbar.  Either of these actions displays a list of common toolbars (but not all toolbars). 
The toolbars that have a check mark next to them are currently visible.  To hide a toolbar, 
click it to remove the check mark. To display a toolbar, click it to add a check mark.   

If the toolbar that you want to hide or show does not appear on the menu list, 
select View -> Toolbars -> Customize (or select Customize from the shortcut menu that 
appears when you right-click a toolbar). Excel displays its Customize dialog box, shown 
in Figure 3. The Toolbars tab of this dialog box shows a list of all toolbars that are 
available —the built-in toolbars, plus any custom toolbars.  The toolbars that have a 
check mark next to them are currently visible. To hide a toolbar, click it to remove the 
check mark. To display a toolbar, click it to add a check mark. When you’re finished, 
click the Close button. 
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Figure 2.  An active cell D5. 
 

 
 
Figure 3.  Toolbar customization. 
 
 
6.3 Working with Files 
 
 Excel’s primary file type is called a workbook file. When you open a workbook in 
Excel, the entire file is loaded into memory, and any changes that you make occur only in 
the copy of the file that’s in memory. If the workbook is large, your system may not have 
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enough memory to hold the file. In such a case, Windows uses disk-based virtual memory 
to simulate actual memory (this slows things down consider-ably).  When you save the 
workbook, Excel saves the copy in memory to your disk, overwriting the previous copy 
of the file. 
 

The following is a summary of various types of files that Excel supports directly: 
 

BAK Backup file 
XLA  Excel add-in file (several add-ins are supplied with Excel, and you can 

create your own add-ins) 
XLB Excel toolbar configuration file 
XLC  Excel 4 chart file 
XLL  Excel link library file 
XLM  Excel 4 macro file 
XLS  Excel workbook file 
XLT  Excel template file 
XLW  Excel workspace file 

 
 Although Excel’s default file format is an XLS workbook file, it also can open 
files generated by several other applications. In addition, Excel can save workbooks in 
several different formats. A list of file formats that Excel can read and write is as follows: 
 

WKS  1-2-3 Release 1 spreadsheet format 
WK1  1-2-3 Release 2 spreadsheet format 
WK3  1-2-3 Release 3 spreadsheet format 
WK4  1-2-3 for Windows spreadsheet format 
WQ1  Quattro Pro for DOS spreadsheet format 
WB1  Quattro Pro for Windows spreadsheet format** 
DBF  dBASE database format 
SLK  SYLK spreadsheet format 
WB1  Quattro Pro for Windows spreadsheet format 
HTM/HTML  Hypertext Markup Language files 
CSV  Comma-separated value text file format 
TXT  Text file format 

 
 

Excel’s workbook files are subject to the same rules that apply to other Windows 
files. A filename can be up to 255 characters, including spaces. This enables you (finally) 
to give meaningful names to your files. You can’t, however, use any of the following 
characters in your filenames: 

\ (slash) 
? (question mark) 
: (colon) 
* (asterisk) 
“ (quote) 
< (less than) 
> (greater than) 
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| (vertical bar) 
 

You can use uppercase and lowercase letters in your names to improve 
readability. The file names aren’t case-sensitive, however.  The Save As dialog box has a 
drop-down menu labeled Tools. When you click this menu, one of the options displayed 
is labeled General Options. Selecting this item displays the Save Options dialog box, 
shown in Figure 4. This dialog box enables you to set the following options: 
 
Always create backup: If this option is set, the existing version of the workbook is 
renamed as a BAK file before the workbook is saved. Doing this enables you to go back 
to the previously saved version of your workbook. Some users like to use this option 
because it adds another level of safety. Just be aware that your worksheet files will take 
up about twice as much disk space, so it’s a good idea to delete the backup files 
occasionally. 
 
Password to open: If you enter a password, the password is required before anyone can 
open the workbook. You’re asked to enter the password a second time to confirm it. 
Passwords can be up to 15 characters long and are case-sensitive.  Be careful with this 
option, because it is impossible to open the workbook (using normal methods) if you 
forget the password. 
 

 
Figure 4.  The save options dialog box. 

 
 
 
Password to modify: This option enables you to specify a password that will be required 
before changes to the workbook can be saved under the same filename. Use this option if 
you want to make sure that changes aren’t made to the original version of the workbook. 
In other words, the workbook can be saved with a new name, but a password is required 
to overwrite the original version. 
 
Read-only recommended: If this option is checked, the file can’t be saved under its 
original name. This is another way to ensure that a workbook file isn’t overwritten. 
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6.4 Editing Worksheet Data 
 
(1) Types of Worksheet Data 
As you know, an Excel workbook can hold any number of worksheets, and each 
worksheet is made up of cells. A cell can hold any of three types of data: 

 
o Values 
o Text 
o Formulas 

 
A worksheet also can hold charts, maps, drawings, pictures, buttons, and other 

objects. These objects actually reside on the worksheet’s draw layer, which is an 
invisible layer on top of each worksheet.  We will not discuss the draw layer in this 
lecture. 

 
Here is an Excel workbook with three types of data on it (Figure 5). 
 

 
Figure 5.  Excel data types. 
 
New users often are curious about the types of values that Excel can handle. In 

other words, how large can numbers be? And how accurate are large numbers? Excel’s 
numbers are precise up to 15 digits. For example, if you enter a large value, such as 
123,123,123,123,123,123 (18 digits), Excel actually stores it with only 15 digits of 
precision: 123,123,123,123,123,000. This may seem quite limiting, but in practice, it 
rarely causes any problems. 
 
(2) Formatting Values 
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 Values that you enter into cells normally are unformatted. In other words, they 
simply consist of a string of numerals. Typically, you want to format the numbers so that 
they are easier to read or are more consistent in terms of the number of decimal places 
shown. 
 

Figure 6 shows two columns of values. The first column consists of unformatted 
values. The cells in the second column have been formatted to make the values easier to 
read. If you move the cell pointer to a cell that has a formatted value, you find that the 
formula bar displays the value in its unformatted state. This is because the formatting 
affects only how the value is displayed in the cell. 

 

 
Figure 6.  Value formats. 

 
 A very convenient way to format values is via using the Excel’s Format Cells 
dialog box (Figure 7).  This is a tabbed dialog box. For formatting numbers, you need to 
use the tab labeled Number.  Several ways exist to bring up the Format Cells dialog box. 
Start by selecting the cell or cells that you want to format and then do the following: 
 

o Select the Cells to be formatted. 
o Right-click and choose Format Cells from the shortcut menu. 
o A dialog box will be displayed (Figure 7). 
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Figure 7.  The number tab of the format cells dialog box. 
 

The Number tab of the Format Cells dialog box displays 12 categories of number 
formats from which to choose. When you select a category from the list box, the right 
side of the tab changes to display appropriate options. For example, Figure 8 shows how 
the dialog box looks when you click the Number category. 

 
The Number category has three options that you can control: the number of 

decimal places displayed, whether to use a comma for the thousand separator, and how 
you want negative numbers displayed. Notice that the Negative numbers list box has four 
choices (two of which display negative values in red), and the choices change depending 
on the number of decimal places and whether you choose to use a comma to separate 
thousands. Also, notice that the top of the tab displays a sample of how the active cell 
will appear with the selected number format. After you make your choices, click OK to 
apply the number format to all the selected cells. 
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Figure 8.  Options for the number category. 
 
 
The following are the number-format categories, along with some general comments 
(Figure 9): 
 

o General: The default format; it displays numbers as integers, decimals, or in 
scientific notation if the value is too wide to fit in the cell. 

o Number: Enables you to specify the number of decimal places, whether to use 
a comma to separate thousands, and how to display negative numbers (with a 
minus sign, in red, in parentheses, or in red and in parentheses), as shown in 
Figure 8. 

o Currency: Enables you to specify the number of decimal places, whether to use 
a dollar sign, and how to display negative numbers (with a minus sign, in red, in 
parentheses, or in red and in parentheses). This format always uses a comma to 
separate thousands. 

o Accounting: Differs from the Currency format in that the dollar signs always 
line up vertically. 

o Date: Enables you to choose from 15 date formats. 
o Time: Enables you to choose from eight time formats. 
o Percentage: Enables you to choose the number of decimal places and always 

displays a percent sign. 
o Fraction: Enables you to choose from among nine fraction formats. 
o Scientific: Displays numbers in exponential notation (with an E): 2.00E+05 = 

200,000. 2.05E+05 = 205,000. You can choose the number of decimal places to 
display to the left of E. 
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o Text: When applied to a value, causes Excel to treat the value as text (even if it 
looks like a value). This feature is useful for items such as part numbers. 

o Special: Contains four additional number formats (Zip Code, Zip Code +4, 
Phone Number, and Social Security Number). 

o Custom: Enables you to define custom number formats that aren’t included in 
any of the other categories. Custom number formats are described in the next 
section. 

 

 
Figure 9.  Value format category. 
 

(3) Alignment 
 
When you enter text in a cell, Excel aligns the text with the left edge of the cell.  Values, 
on the other hand, are displayed right aligned in the cell.  To change the alignment of a 
cell’s contents, select the cell and then click the appropriate button on the Formatting 
toolbar. The relevant buttons are as follows: 
 

o Left 
o Center 
o Right 
o Merge and center 

 
(4) Validating Data Entry 
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 In Excel 2000, you can specify the type of data that a cell or range should hold. 
For example, you might develop a spreadsheet that will be used by others. Assume that 
the worksheet has an input cell that is used in a formula. This particular cell might require 
a value between 1 and 20 to produce valid results in the formula. You can use the data-
validation feature to display a message if the user enters a value that does not fall 
between 1 and 20.   

 
To set up data validation, select the cell or range of cells that you want to validate 

and then choose Data -> Validation. Excel displays the Data Validation dialog box, with 
its three tabs (Figure 10).  For example, if a 21 is entered for this cell, an error message 
will be popped out (Figure 11). 
 

 
Figure 10.  Data validation a cell or range. 
 

 
Figure 11.  Message box a data validation. 
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Class Exercises 
(1) Formatting cell values – Figure 6 on page 8 and Figure 9 on page 11. 
(2) Data validation – Figure 10 on page 12. 
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